Asciinema: upload failed: <urlopen error [Errno 32] Broken pipe>



First 1001 thanks for this really nice piece of software and webservice, it’s great :slight_smile:

… but I have some trouble to upload content
I messed things up creating 2 accounts on and stopped an upload because I thought it was not working and then I revoke the tokens to see if it was better, but no success to upload any ascii on the website.

I tried to follow these advices Why `upload failed: Invalid or revoked install ID`?

but when I try to upload an ascii movie, I still get

asciinema upload aquicktest
asciinema: upload failed: <urlopen error [Errno 32] Broken pipe>
asciinema: retry later by running: asciinema upload aquicktest

I’m using asciinema 2.0.2 installed with pip on debian 9


1 Like


Can you try and run pip and see if upgrading does anything to fix things

pip install asciinema --upgrade

or similar, depending on your setup. Once done, try recording a different terminal session and go with the flow uploading when asked to. See if that does help.

Also, making sure the recorder token that is within the config file is valid (ie not revoked)

You can verify the tokens for your account on the asciinema website user section

Locally, your recorder token should be in the following file


Make sure it is added to your account and not revoked

here’s a cast showing how one would go about resetting the recorder token


1 Like


The broken pipe error is likely related to this:




ok, my asciicast was 88 Mo big (very spectacular :slight_smile: , that’s why